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• MolProbility  
 validate macromolecule  
 
• Chimera 
 molecular graphics 
 
• Ligplot and ligplot+ 
 biomolecule-drug interactions 



3 

• clear  
• pwd  print working directory 
• ls  list  
• mkdir make directory 
• cd  change directory 
• mv  move 
• rm  remove file 
• rmdir  remove directory 
• man manual 

 
• cat   
• more 
• vi 
• exit 

Basic Linux Commands 
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Use SSH/SCP clients to connect to a remote computer, and/or to 
transfer files between computers. 
 
SSH/SCP client for windows: 
• putty https://www.putty.org/  

• Xming https://sourceforge.net/projects/xming/  (X Server) 
• WinSCP https://winscp.net/eng/download.php  

 
• MobaXterm http://mobaxterm.mobatek.net/download.html 

https://www.putty.org/
https://www.putty.org/
https://sourceforge.net/projects/xming/
https://winscp.net/eng/download.php
https://winscp.net/eng/download.php
http://mobaxterm.mobatek.net/download.html
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Launching mobaXterm 
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Choose Session  →  SSH  

IP  
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Display Xterm in Mac 
  
Create a file "config" under "~/.ssh/" 
$ vi config 
------------------------------------- 
Host username 
Hostname 123.123.123.123 
User=login_id 
ForwardX11 yes 
------------------------------------- 
  
Then, login with the following comment: 
$ ssh –Y  username@ip_address 



MolProbility 

• all-atom structure validation for macromolecular 
crystallography 

 

• Server 

 http://molprobity.biochem.duke.edu/ 

• Standalone program 

 https://github.com/rlabduke/MolProbity 

 A standalone version was installed. 
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https://github.com/rlabduke/MolProbity
https://github.com/rlabduke/MolProbity
https://github.com/rlabduke/MolProbity
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## 1cqp.pdb from PDB 
$pwd 
$ls 
$cd FCDD_tutorials 
$ls 
 
$molprobity 1cqp.pdb 
  

## 1cqp.pdb from PDB 
$pwd 
$ls 
$cd FCDD_tutorials 
$ls 
 
$molprobity 1cqp.pdb 
  

V 
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MolProbity: structure validation  
Web service for all-atom contact, conformation, & geometry analysis of x-ray or 
NMR models, with automated correction of Asn/Gln/His flips. As a structure user, 
you can evaluate reliability of the parts you care about. 

http://molprobity.biochem.duke.edu/ 
1cqp 
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$molprobity 1cqp.pdb $molprobity 1cqp.pdb 

$ls 
$cd molprobity_1cqp 
$ls  

$ls 
$cd molprobity_1cqp 
$ls  
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$cd molprobity_1cqp 
$ls 
 
$vi 1cqp.rama 
 
$grep "SUMMARY:" 1cqp.rama 
 
$grep "OUTLIER" 1cqp.rama 
 
$grep "OUTLIER" 1cqp.rota 

  

$cd molprobity_1cqp 
$ls 
 
$vi 1cqp.rama 
 
$grep "SUMMARY:" 1cqp.rama 
 
$grep "OUTLIER" 1cqp.rama 
 
$grep "OUTLIER" 1cqp.rota 
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Vi Editor 

http://www.atmos.albany.edu/daes/atmclasses/atm350/vi_cheat_sheet.pdf 
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## download 1cqp.rama.pdf to local computer 
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Protein Backbone Structures and 
Ramachandran Plot 



21 
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$king 1cqp.rama.kin $king 1cqp.rama.kin 



UCSF CHIMERA 
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https://www.cgl.ucsf.edu/chimera/ 
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https://www.cgl.ucsf.edu/chimera/download.html 
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https://www.cgl.ucsf.edu/chimera/current/docs/UsersGuide/ 
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https://www.cgl.ucsf.edu/chimera/current/docs/UsersGuide/tutorials/framepdbintro.html 
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https://www.rcsb.org/pages/aboutus 
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Launching Chimera 
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Choose File  → Open     => open local file 
Choose File  → Fetch by ID   => fetch entry from PDB 
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Command: open 1cqp 

fetch the entry with ID 1cqp from the 
Protein Data Bank (PDB) 

Choose Tools  →  General Controls → Command Line 
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Choose Favorites  →  Add to Favorites/Toolbar to place some icons on the toolbar.  
This opens the Preferences 
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Auto Start 
 
On Toolbar 
 
In favorites 

This opens the Preferences, set to Category: Tools.  
In the On Toolbar column, check the boxes for: 

• Side View (under Viewing Controls) 
• FindHBond (Structure Analysis) 
• Find Clashes/Contacts (StructureAnalysis) 
• Reply Log (Utilities, the last section) 
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The arrow keys can be used to broaden (↑), narrow (↓), or invert (→) a selection. 

You can interact with Chimera using menus and/or commands. The basic features 
of Chimera are available either way, but not all command functions are available 
in menus or graphical interfaces, and not all menu or graphical interface functions 
are available in commands.  



36 Command: modelcol white 
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Command: preset apply int 2 



• A preset is a predefined combination of display settings. Choosing an entry in the Presets menu 
applies its settings and is much easier than adjusting the many settings individually. Presets are 
provided for a handful of usage scenarios; of course, many more combinations of settings are 
possible. See also: the preset command, the New Molecules preferences 

• Interactive presets are meant for interactive manipulation and analysis. They may change what 
items (atoms, ribbons, surfaces) are displayed and how they are colored. The background color is 
set to black. 

• The ribbons preset shows most peptide and nucleic acid chains as ribbons, plus atomic detail 
(excluding hydrogens on carbon atoms) for residues within 3.5 Å of a ligand residue or metal ion. 
Atomic detail is also used for chains that are very short. Nucleic acids may be shown with special 
sugar and base representations (as produced by Nucleotides), with the level of abstraction 
dependent on size. 

• The all atoms preset displays all atoms and bonds as wires with heteroatom colorcoding. Carbons 
are shown in the model colors so that models will be distinguishable from one another. 

• The hydrophobicity surface preset shows amino acid hydrophobicity in the Kyte-Doolittle scale 
with colors ranging from dodger blue for the most hydrophilic to white at 0.0 to to orange red for 
the most hydrophobic (different color-codings can be applied with rangecolor or Render by 
Attribute). Surfaces of nonpeptides will be colored to match the underlying atoms instead. 

• Publication presets are intended for generating images for presentation and publication. They do 
not change what items are displayed or their colors, but may change their styles, and the 
background color is set to white. For example, choosing a preset with rounded ribbon or licorice 
will not turn on ribbon display, but will adjust any currently displayed ribbon segments; similarly, 
only the currently displayed atoms and bonds will be shown as sticks. Publication presets may 
decrease interactive performance because finer divisions are used to depict curved objects 
(molecular surfaces, ribbons, etc.). Individual display parameters are discussed in more detail in 
the tips on preparing images. 
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Examples: 
preset apply int 1 
- apply the ribbons interactive preset 

preset list pub 
- list all publication presets in the Reply Log 
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Choose Presets  →  Interactive 3 
Use mouse to click and select one ligand  
Choose Actions  →  Atoms/Bonds 3 → sphere 

Command:  
preset apply int 3 
select :311.A  
rep sphere :311.A  

Command:  
preset apply int 3 ; select :311.A ; rep sphere :311.A  

“hydrophobicity surface” preset:  

from dodger blue for the 
most hydrophilic, to white, to 
orange red for the most 
hydrophobic. 
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“hydrophobicity surface” preset: from dodger blue for the most hydrophilic, 
to white, to orange red for the most hydrophobic. 

Command:  
setattr m stickScale 2 ; color yellow ligand & C 

The binding pocket is primarily orange red, 
indicating its hydrophobic character. 
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Command:  
rangecol kdHydrophobicity min medium purple 0 white max tan 
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Choose Presets  →  Publication 1 
Choose Tools  →  Surface/Binding Analysis → Coulombic Surface Coloring 



45 Command: light mode ambient 
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Command: close all; open 1cqp 
       preset apply int 3  
         

Choose Tools → Viewing Controls  → Side View 

Side View 



47 
scale 

adjust the clip plane 



48 



49 



50 

https://www.cgl.ucsf.edu/chimera/current/docs/UsersGuide/quickref.pdf 
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Coloring by B-Factor 

Command: rangecolor bfactor key 2 blue 30 red 50 yellow 
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Command: preset apply int 1; col yellow @/bfactor>70  
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Electron Density Map 

Command: close session 
       open 2fma; modelcol white; preset apply int 2;  
       open edsID:2fma 

Fetch the density map for 2fma from the Electron Density Server 

Click the little eye icon 
on the Volume Viewer 
dialog to hide the 
electron density for now. 
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Command: show :168-170 
       focus  
                  disp :167,171@n,ca,c,o 
       rep stick 
       setattr m stickScale 0.5 
       sel :168,170 & without CA/C1' 

Volume Viewer 
Choose Features  →  Zone 



56 

Click on Zone 

This limits the density display to a zone near the selected atoms. 
After this, the selection can be cleared. 
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Volume Viewer 
Choose Features  → Surface and Mesh Options 

Set the zone Radius to be 1.96 Å 
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To modify the color, click on color well 

To change the level, drag the threshold to the left or right with the 
mouse or type a different value into the Level field below the 
histogram; to see more density, move the threshold to the left. 

Level 2.06,  
Color (RGBA) 1.0 0.0 1.0 0.6  
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To add another contour level, Ctrl-click on the histogram. 

Level 0.426,  
Color (RGBA) 0.36 1.0 1.0 0.4 
Style surface  
turned on Surface smoothing iterations 2 factor 0.3 

v 



60 

Command: close all; open 1cqp 
       modelcol white; preset apply int 2;  
       open edsID:1cqp 
       show :311.A; focus;  
       disp :311.A 
                  rep stick; setattr m stickScale 0.5 
                  sel :311.A 

Show the density map of ligand (res ID: 311, chain ID: A) in 1cqp 
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Each file of atomic coordinates opened in Chimera becomes a model with an associated 
model ID number. Surfaces and other types of models also have ID numbers. 

Command: close 1 
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Find H-bond between ligand and protein 

Choose Select → Residue → 803 

Choose Tools → Structure Analysis → FindHBond 

Click on find hydrogen bonds icon 
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Find contacts between ligand and protein 

Click on Find steric clashes or atomic contacts icon 

Choose Tools → Structure Analysis → Find Clashes/Contacts 
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Metal Geometry 

Choose Tools → Structure Analysis → Metal Geometry 
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Metal Geometry 
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Metal Geometry 
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Match Maker 

Open 1cqp.pdb1 and 1cqp.pdb2 

Choose Tools → Structure Comparison → MatchMaker 



69 Command: mm #0 #1 
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Choose Tools → Structure Comparison → Match Align 

Command: mm #0 #1 show true 
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Choose Select → Chain → B 
Choose Actions → Atom/Bonds → delete 

Command: delete :.B 

Delete Selected Structure 
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Save Selected Structure 

Command: select :311.A 
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Save Selected Structure 

Command: select protein 
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Add Hydrogen 

Choose Tools → Structure Editing → AddH 
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Command: stop 

Choose Files → Quit 
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More than molecular graphics  
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## find hydrogen bond between ligand and protein 
open 1cqp.pdb 
select ligand 
hbonds selRestrict cross showDist true saveFile 1cqp_Hbondinfo.txt 
~sel 
color  byelement ligand 
copy file 1cqp_Hbond.png png width 400 height 300 
#stop 

Chimera Command Line Scripts 
Hbond.com 

$chimera Hbond.com $chimera Hbond.com 

Command: open Hbond.com 

While the command line can be used for many things, the ultimate 
control of chimera is through Python scripts.  

Chimera Python Scripts 

http://www.cgl.ucsf.edu/Outreach/Workshops/UCSF-Fall-2005/09-ScriptDemo/Scripting_Tutorial.html 

https://www.cgl.ucsf.edu/chimera/current/docs/ProgrammersGuide/index.html 



$cd ~/FCDD_tutorials 
$ls 
$cd ~/FCDD_tutorials 
$ls 

Upload the ligand and protein PDB to VM server. 
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LigPlot and LigPlot+ 

https://www.ebi.ac.uk/thornton-srv/software/LIGPLOT/ 
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https://www.ebi.ac.uk/thornton-srv/software/LigPlus/manual2/manual.html 

https://www.ebi.ac.uk/thornton-srv/software/LIGPLOT/manual/ 

https://www.ebi.ac.uk/thornton-srv/software/LigPlus/ 

LigPlot and LigPlot+ 

LigPlot+ is a successor to the original LIGPLOT program. It is run from 
an intuitive java interface which allows on-screen editing of the plots via 
mouse click-and-drag operations.  
1. Superposition of related diagrams 
2. Improved DIMPLOT program 
3. Links to PyMOL and RasMol 
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$cd ~/FCDD_tutorials 
$mkdir ligplot 
$copy 1cqp.pdb ligplot 
$cd ligplot 
$source /opt/setup_ligplot.sh 
$ligplot 1cqp.pdb 311 311 A 

$cd ~/FCDD_tutorials 
$mkdir ligplot 
$copy 1cqp.pdb ligplot 
$cd ligplot 
$source /opt/setup_ligplot.sh 
$ligplot 1cqp.pdb 311 311 A 

https://www.ebi.ac.uk/thornton-srv/software/LIGPLOT/manual/ 

ligplot filename [residue1] [residue2] [chain_id] [-w] [-m] 
[-w] indicates that the ligand is a single water molecule or group of water molecules 
[-m] indicates that the ligand is a single metal ion 
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$ls $ls 
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The input files to LIGPLOT are: 
 
• filename.pdb - Input PDB file holding the coordinates of the protein and 

ligand. 
 

• filename.hhb - List of hydrogen-bonds in the structure. This can either be 
generated by the HBPLUS program, or supplied by any other program in the 
format specified. 
 

• filename.nnb - List of nonbonded contacts in the structure. Again, this can 
either be generated by the HBPLUS program, or supplied by any other 
program in the format specified. 
 

• ligplot.prm - Parameter file containing parameters governing the final 
appearance of the plot. It is automatically created when you first run LIGPLOT. 
It can then be edited using any text-based editor to alter the parameters 
controlling the appearance of the plot - eg colours, text sizes, etc.  

https://www.ebi.ac.uk/thornton-srv/software/LIGPLOT/manual/man5.html 
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The output files produced by LIGPLOT are:  
 
• ligplot.ps - Colour or black-and-white PostScript showing the plotted LIGPLOT 

diagram. This can be viewed using any PostScript viewer, or plotted on any 
PostScript printer.  

• ligplot.pdb - Output file, in PDB format, of the final flattened molecules (ligand 
and interacting protein residues) as shown in the plot. This file can be loaded 
into any standard molecular graphics package, and appears as a very flat 
molecule(!).  

• ligplot.hhb - Output file, in LIGPLOT format, of just those hydrogen bonds in 
the original filename.hhb file that were used by LIGPLOT in producing the final 
picture.  

• ligplot.nnb - Output file, in LIGPLOT format, of just those hydrophobic contacts 
in the original filename.nnb file that were used by LIGPLOT in producing the final.  

• ligplot.bonds - Output file listing of bonds and bond-types in the final LIGPLOT 
picture.  

• ligplot.frm - Output file, in PDB format, of the molecules shown in the plot, prior 
to flattening. You can view this file using any molecular graphics program (eg 
Rasmol) to see only those residues that interact with the ligand. 

• ligplot.rcm - Output file listing all the residues on the plot, together with the x-y 
coordinates of their centres of mass. The file provides a useful starting point if 
positional restraints on the residues of the plot are required.  

• ligplot.drw - File for input to the Java-based LIGPLOT editor, LigEd.  
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$cat ligplot.sum $cat ligplot.sum 
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$more ligplot.hhb 
$more ligplot.nnb  
$more ligplot.hhb 
$more ligplot.nnb  
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$convert ligplot.ps ligplot.gif 
$display  
$convert ligplot.ps ligplot.gif 
$display  

$ghostscript ligplot.ps $ghostscript ligplot.ps 
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$java -jar /opt/ligplot/LigPlus/LigPlus.jar $java -jar /opt/ligplot/LigPlus/LigPlus.jar 
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Choose File → Open → PDB file 

1cqp 
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To move any object on the plot just click and 
drag it using the left mouse button. 

Use the left mouse button to click-and-drag on any blank 
area of the plot to pan around the plot.  
Use the right mouse button to click-and-drag on any 
blank area of the plot to zoom in and out of the plot.  
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To edit the text label on the plot, you can 
select the text item by right-clicking on it. 
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Choose File → Write PS file  
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Change on/off parameter 

ligplot.prm 
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Change size definitions 
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Change colors  



96 



97 

Multiple plots Choose File → Add 
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